Embedded data based on URL parameter

MsIreenMsIreen FinlandCommunity Member, XMPN Member Superuser ✭✭✭✭
edited November 2020 in Best Practices

Embedded data based on URL parameter

Hi all,

I am struggling to set embedded data field value based on whether a URL contains a certain parameter.

I am using a Referer and Q_URL fields and want to set up embedded data based on, e.g. if the URL contains word "product" in it. The link is recorded correctly, but the Embedded data field is not populated. I use the following logic in the Survey flow:

I tried recording the value of the Referer / Q_URL in another ED field "Link1" and tried to set the value from that field, but it is also not working. The Link1 field is populated with the correct URL, but the ED field i try to fill in is again empty..

Tagged:

Best Answer

  • MsIreenMsIreen FinlandCommunity Member, XMPN Member Superuser ✭✭✭✭
    Accepted Answer

    Oh well... I just started setting up the ED field after the End of Survey message in the Survey flow 🤪

    Moved it up and it is working fine

Answers

  • RadamRadam Miami, FlCommunity Member, XM Advocate Guru ✭✭

    You need to set the embedded data prior to the branch logic

    And since its a built in variable you just selected it from the dropdown.

  • MsIreenMsIreen FinlandCommunity Member, XMPN Member Superuser ✭✭✭✭

    @Radam i did that in different ways, and as i mentioned, it is populated correctly, but the ED field i need is not :(

  • RadamRadam Miami, FlCommunity Member, XM Advocate Guru ✭✭

    To help actually see what is in the ED field you can add a text question and pipe the value of the ED into the text. I use this to troubleshoot variables to ensure what I'm looking for is actually what I'm getting.

  • MsIreenMsIreen FinlandCommunity Member, XMPN Member Superuser ✭✭✭✭

    Thanks, I was actually piping the URL part, not the ED Apparently by the end of this year my mental capabilities have drained :D

Sign In to Comment