Access Denied Error When Trying to Post Comment

TomGTomG Raleigh, NCCommunity Member Wizard ✭✭✭✭✭

Access Denied Error When Trying to Post Comment

What would cause the following error when trying to post a comment?

Access Denied
You don't have permission to access "http://www.qualtrics.com/community/post/comment/?" on this server.
Reference #18.e40c1060.1517330132.22b5a0e9

Tagged:

Comments

  • 2baprogrammer2baprogrammer ArizonaCommunity Member - Trial User Guru ✭✭

    @TomG have you tried clearing your browser history/cache and re logging in to post? My next guess might be which browser your using. Has anyone else had problems posting?

  • AnthonyRAnthonyR Tucson AzFounding Community Member Superuser ✭✭✭✭

    @TomG I'd actually venture a guess that this was a symptom of the changeover to SSO that apparently happened today.

  • TomGTomG Raleigh, NCCommunity Member Wizard ✭✭✭✭✭

    Thanks @AnthonyR and @2baprogrammer. Good theories. It turned out that it didn't like the content of the post. Specifically, it doesn't like anything that looks like a url, even if it is marked as code. In this case, I was trying to demonstrate to someone how they would pipe values into a redirect url. I think "Access Denied" is a rather misleading error message.

  • AnthonyRAnthonyR Tucson AzFounding Community Member Superuser ✭✭✭✭

    @TomG said:
    Thanks @AnthonyR and @2baprogrammer. Good theories. It turned out that it didn't like the content of the post. Specifically, it doesn't like anything that looks like a url, even if it is marked as code. In this case, I was trying to demonstrate to someone how they would pipe values into a redirect url. I think "Access Denied" is a rather misleading error message.

    That seems like a bad error at best. And the actual cause might make it even worse. Thanks for sharing!

  • @TomG - would you mind sending me a DM with the content that you were unable to post. I'd like to do some testing on our end to make sure we can get this fixed & other users don't run into it.

  • TomGTomG Raleigh, NCCommunity Member Wizard ✭✭✭✭✭

    @Tyler - Sent. Thanks!

  • 2baprogrammer2baprogrammer ArizonaCommunity Member - Trial User Guru ✭✭

    Ah that makes sense, awesome thanks for sharing the info @TomG

  • I wanted to give an update on this post - we've been working with @TomG to get to the bottom of this one.

    The good news is that this doesn't seem to be a widespread community issue. We ran a few different tests and were able to post the content fine. If anyone else does run into this issue, please raise it to me.

    Completely agree the error message leaves a lot to be desired - we'll be looking into improving this in the future!

  • AxelSAxelS ArgentinaCommunity Member Guru ✭✭
    edited March 2019

    Hello, I wanted to report on an issue I had: I wanted to post an answer to a question about the qualtrics api, and I got this error message when I typed the word "cur_l" (I separated it with an underscore for obvious reasons), which didn't contain a complete cur_l, it was just a suggestion for him to try it to see if he got any error code.

  • LaurenKLaurenK Seattle, WA, USACommunity Administrator Administrator

    Hi @fstram! Did you receive the same reference number?

  • AxelSAxelS ArgentinaCommunity Member Guru ✭✭

    @LaurenK said:
    Hi @fstram! Did you receive the same reference number?

    No, it isn't exactly the same reference number. Below I copy the entire error message:

    "You don't have permission to access "http://www.qualtrics.com/community/post/editcomment/12864?" on this server.

    Reference #18.565d2ac8.1554236636.78f3cc14"

  • LaurenKLaurenK Seattle, WA, USACommunity Administrator Administrator

    Thanks for letting me know, @fstram! Would you mind sending me a DM with the content that you were unable to post so I can do some additional testing?

  • EftychiaEftychia AmsterdamCommunity Member Qubie ✭

    I have the same problem with a survey I am trying to run in Iran. Please see the attached file. Any suggestions? Does it have to do with the country?

  • LaurenKLaurenK Seattle, WA, USACommunity Administrator Administrator
    edited August 2019

    Hi @Eftychia! Since your issue is in regards to your actual Qualtrics account (and not Qualtrics Community), I'd recommend reaching out to our Support team so they can further investigate this with you!

Sign In to Comment