Email fails inconsistently

lfznlfzn Community Member Qubie ✭

Email fails inconsistently

I am having trouble with emails that fail inconsistently -- no rhyme or reason from what I can tell, and it seems to be a bug. Within Actions/Reporting Tab, all tasks say "completed", but in fact the emails only send 10% of the time.

I would greatly appreciate community help! The survey is considered essential research, as it is part of a hospital response for COVID and needs to be implemented immediately. I have sent 5 emails to Qualtrics with only one response that was of no help. I then just spent an hour on the phone with Qualtrics support -- no resolution -- they said they need to send it to an engineer and they have no idea when that person will get back to me. Given my urgent needs, I am hoping a community member may have experienced this and know a solution / work around. I could try this as an email trigger -- but Qualtrics' support website seems to suggest this is deprecated, or less stable than Actions with an Email Task, so I am hesitant to change things.

I can confirm the failed email behavior by opening up the payload which demonstrates correct email address, and Sent=1 and Status: Done on some tasks that do send; and Status:Pending and Sent=0 on others that do not send. The pending status never updates, and the email never sends. The only other difference between the two payloads on diff'ing the files are the following variables which are present in the sent email payload but not present in the pending email payload:

Task Output
{
...
"exports": {
"context": {}
...
"attachments": [],
...
"payload": {
"Temporary": 0,
"DefaultLanguage": "EN"
}
}

Payloads are otherwise identical.

The only other thing I can think of is some issue with throttling or use limits (like one email every 6 hours?), as it seems that the first email sent after a day or so usually sends, but every subsequent attempt in the following several hours does not send. I have tried this across three different browsers, results appear to be same. They are not improved by deleting cookies.

Best Answer

  • MatthewMMatthewM Chicago, ILCommunity Member Sage ✭✭✭
    Accepted Answer

    Hi @lfzn ,

    This may not be the same as what you're experiencing, but I had a problem in Actions recently where the Actions Reporting said my messages were being sent, even though I was not receiving most of them (they were all addressed to email addresses I have access to). After much digging by Qualtrics support, they told me the following:

    "There is a circuit breaker than prevents the same email (with the same subject and message) from being sent to the same email address more than once in a 24 hour period. With this, if you add some piped text into the email so that it dynamically adds some text from a survey response, such as piping in a text entry question, each email will be unique in the message body and should send without any issues."

    Again, this may not apply to your situation, but I thought I'd share it just the same.

Sign In to Comment