"Invalid Email" Salesforce error

GoldieGoldie Provo, UTFounding Community Member CEP (Chief Executive Paw-ficer)
edited November 2017 in Integrations

"Invalid Email" Salesforce error

I'm using the Trigger and Email Survey to send out my survey from Salesforce, but whenever I try to trigger my workflow rule, I get the error "Invalid Email" in my debug email. I have the Email field selected correctly in my Trigger an Email, so what could be happening?

Best Answer

  • GoldieGoldie Provo, UT CEP (Chief Executive Paw-ficer)
    Accepted Answer

    I contacted the support team today and got this one figured out. They told me that this message means Qualtrics is not able to find the email address of the recipient in Salesforce mostly likely because it is connected to the wrong account.

    The survey was shared and the survey owner had not connected their account to Salesforce (this was my issue). The owner of the survey must connect to Salesforce from their account - we changed ownership of the survey to my account and I linked my account - everything is working correctly now.


  • AnneGAnneG Austin, TexasFounding Community Member, Community Member Guru ✭✭

    This won't be totally helpful, but I remember running into this same thing a few months ago. The issue ended up being with something else entirely . . . at the time I wasn't able to get any test surveys to send within my sandbox environment. I would suggest digging in with your Salesforce admin and/or calling Q Support and asking for an integration specialist. Good luck.

  • NK_TripathiNK_Tripathi [email protected]Qualtrics Partner Guru ✭✭

    Another luck to try - Probably checking the Email attribute is not blank of what you have set the work flow rule.

    Else contact Q Support, they would be log in to your account and help you promptly. They are the best resources.


  • NK_TripathiNK_Tripathi [email protected]Qualtrics Partner Guru ✭✭

    Is this resolved yet? I got the similar Issue today and found that when I was setting up the case I need to select the Contact and have primary point of contact as Email and it worked well.

Sign In to Comment