Qualtrics XM Response Export Automation

StaffordStafford CaliforniaCommunity Member, Qualtrics Brand Admin Qubie ✭

Qualtrics XM Response Export Automation

Has anyone hit the FTP error code: CDAP_FTS_004 when trying to use the Response Export Automation feature?

It feels like I'm missing a setting which could be on the destination server site.

If it's something on my Qualtrics setup, what does the code mean and how do I get the CSV file to uploading into my server account?

Any ideas would be helpful.

Thanks,

Stafford

Answers

  • qjkqjk Community Member, Qualtrics Brand Admin Qubie ✭

    I am running into this same error when I am setting up a Qualtrics EX Response Export Automation. I have not come across a solution yet. We already checked our firewall to make sure that isn't blocking files from being saved to our SFTP server space. We even set up a dedicated username/password pair as suggested by Qualtrics, but still get the following email message from Qualtrics when it runs. It would also be nice if Qualtrics provided a way to test these connections without having to wait to do it once at the top of each hour. This is very frustrating when I'm just trying to set up a connection for a Response Export Automation.


    Qualtrics Automation Summary


    Starting job execution at Wed Aug 19 17:00:28 UTC 2020 (ID: TIMER_1597856400000-OC_zOaMdA2JNEglWjH)

    Response Export Task

    Successfully exported 360 responses from SV_7QgCIqITR7pMFXn

    File Export Task

    Failed due to: Unable to fulfill request with the given parameters. (CDAP_FTS_004)

  • afclark82afclark82 London, ONCommunity Member Qubie ✭

    Hi all.

    Don't know if you have figured this out yet, but I worked through a whole bunch of solutions (including whitelisting Qualtrics IP) without success.

    One thing I noticed when looking at the SSH Logs on my linux server, was that the system time did not match network time. I ran NTP settings and everything worked.

    Can't guarantee it will work but an idea.

    Cheers,

    Andrew

  • DanB1DanB1 CT, USACommunity Member Qubie ✭

    I fixed this error on my end by shortening the destination path in the SFTP automation download since the new dedicated user account set up for this is automatically mapped to only the subfolders and does not have permissions to the root directory. Shorten your path and the automation may work.

  • StaffordStafford CaliforniaCommunity Member, Qualtrics Brand Admin Qubie ✭

    Thanks for the suggestions as you got me on the right path.

    I had to go back into my Macromedia days of web design.

    My Qualtrics SFTP Settings "Processed Directory" path was at fault.

    The vague error message read: "Failed due to: Unable to fulfill request with the given parameters. (CDAP_FTS_004)".

    I was convinced that my error was "host" or "port" related, but in fact, I had written an absolute destination path that was incorrect. In fact, the shorter relative path correction eliminated the error and the export automation worked as advertised.

    Relative path: ~/htdocs/TestUpLoad

    Case Solved.

    Stafford Cox

    [email protected]

  • DanB1DanB1 CT, USACommunity Member Qubie ✭

    😉 Glad it worked! (I ran into the same cryptic error and figured it out recently.)

  • colin5colin5 Community Member Qubie ✭

    We ran into this too. I'm guessing that customers like us will be seeing more of this as they migrate from the API to using response export automation.

    Can someone share a) the exact home dir on the sftp server & b) the exact "Processed directory" string for a successful setup? Based on our experience with this, it seems that this is the trickiest part of setup.

    Maybe Qualtrics can then update the corresponding step here:

    https://www.qualtrics.com/support/survey-platform/data-and-analysis-module/data/download-data/response-export-automations/

  • colin5colin5 Community Member Qubie ✭

    It looks like SFTP using AWS Transfer Family is not yet supported, because when we tried this with SFTP on EC2 it worked fine.

    Example of settings that worked:

    Home dir for sftp user: "/home/fakeuser1"

    Folder created under this user's home for the files: "/home/fakeuser1/anotherdir"

    Value of "Processed Directory" in Qualtrics UI for response export automations: "anotherdir"

Sign In to Comment