Response mapping unable to login to Salesforce

jonfjonf Community Member Qubie ✭

Response mapping unable to login to Salesforce

Hi. I have been using response mapping for quite a while, but ran into an issue starting last night where the response trigger throws an Error. "Salesforce Response Mapping: Unable to login to salesforce, invalid credentials. Salesforce API error: INVALID_LOGIN: Invalid username, password, security token; or user locked out.". I figured the password had expired, but when I go to my survey, and click on response mapping under Tools, it successfully logs in to Salesforce and retrieves my data. The other strange thing is that once I do that, the response mapping trigger starts working until the SF auth cookie times out, and then it starts throwing the login error again. Has anyone experienced anything similar?

Thanks,
Jon

Tagged:

Best Answer

  • LaurenKLaurenK Seattle, WA Administrator
    Accepted Answer

    Hey @jonf! As @Kate previously mentioned, this is a known issue that our engineering team is currently working to resolve. If you or any other Community members are experiencing this, please reach out to our wonderful Support Team. One of our Product Specialists will be able to escalate this accordingly so we can note that your account has also been impacted.

Answers

  • KateKate Community Member, Product Ideas Superuser ✭✭✭✭
    edited May 2018

    Have you ever sucessfully created a new survey response object? If not- I would have your SF admin ensure that your user permission set is able to use. It could be as simple as your user type is not allowed to send data in using API; just read access.

    I frequently get this error connecting the programs. My organization has single sign on that complicates this process frequently. I have the following 2 tips which have greatly reduced my rate of incidence:

    1. I always log into SF first in a separate tab. Then I connect Qualtrics. This allows me to log utilizing SSO first. Then, when I try to establish the link with Qualtrics, as it is logging in it simply verifies that I want to connect to the one I am logged into.

    2. I always have lots of issues when I move from Sandbox environments to Production. Namely- Qualtrics doesn't let me exist in 2 areas at once (E.G. my existing "Production" Surveys will NOT run if I am testing a new survey in a Sandbox environment. I try to time my tests in "off" hours, and need to ensure I connect Qualtrics with production when I am done. My whole Qualtircs account will only stay connected to one environment or the other). So be very careful to pay attention to where you are logged in on SF, and how/when you are connecting Qualtrics. This should help you at least troubleshoot.

    3. 2b. Related to item 1- Log into SF first, then move into "Training" or "Develop" there. Remember to log out of "Production" before connecting Qualtrics. This helps you know each product is only working in 1 environment at a time.
  • jonfjonf Community Member Qubie ✭

    The response trigger has been working for a while. I don't think it's a permission issue because once I force the Qualtrics UI to login to Salesforce, the response mapping stops giving me the invalid login error and starts updating the response object in Salesforce as expected. It seems to just be an issue with the response trigger authenticating to Salesforce when I haven't already done so in the UI.

  • KateKate Community Member, Product Ideas Superuser ✭✭✭✭

    You won't believe this, but this wasn't happening to me. But it happened yesterday (I thought nothing of it) and it's happening again today.

    I'll call support to see if Qualtrics has been doing any editing to the integration features; I'll let you know if I find anything useful out.

    Otherwise I know my org is upgrading to Lightening... I wonder if something in their development process is messing with it.

  • jonfjonf Community Member Qubie ✭

    Glad it's not just me. Thanks for letting me know.

  • KateKate Community Member, Product Ideas Superuser ✭✭✭✭

    Update: Known issue. It is on Qualtric's end. It has been escalated but the engineers are working on it.

    In the meantime, he did say we have identified a "fix" (log back in). Also, in order to push any missed responses, use the "survey retake" link; this will push the response into salesforce without having to manually input them.

  • GuillermoKankGuillermoKank MiamiCommunity Member Qubie ✭

    Hi @Kate and @LaurenK , is it resolved? I had the same issue of @jonf , its appear to renew token in actions-> task , but after the renew nothing happens and still the same error. We are migrating to Qualtrics but this have a high impact because its not created the survey response in Salesforce. Thanks!

  • KateKate Community Member, Product Ideas Superuser ✭✭✭✭

    @GuillermoKank My issue was resolved a week or so after positing here. All of my SF integrations are set up via the Survey>Tools>Salesforce method, however. Perhaps this might resolve your issue?

  • GuillermoKankGuillermoKank MiamiCommunity Member Qubie ✭

    Thanks @Kate ! i made in the two ways: as you said, survey>tools> salesforce >create survey response(i think its the old ways) and with tools> actions> create survey response and task (new way). In the both throw the same error(the old ways its more descriptive and useful, its the same error of the first thread)

  • KateKate Community Member, Product Ideas Superuser ✭✭✭✭

    @GuillermoKank I would call support, or connect with your tech team. It sounds like you're unable to access the API for some reason. Perhaps it is as simple as having the wrong permission set in SF? Or your Qualtrics Account isn't authorized to use the integration? I suspect that although the error codes are the same, this is unrelated to the issue that the Original Poster and myself were having.

  • GuillermoKankGuillermoKank MiamiCommunity Member Qubie ✭

    Yes its the same error , its was resolved! I copy what qualtrics support said: Most of the time when we see the OAuth token error, that is because the person setting up the Salesforce is not the owner of the survey. Could you verify that you are the owner of the survey(the survey was made by you and not shared with you)?
    That was right, we use an account for create surveys and workflow of salesforce/triggers, and another to create survey responses, always have to be the owner of the folders,survey and project to create survey response. So the rule is create the project, triggers and survey response with the same user . Thanks Kate

Sign In to Comment