Génération d’un fichier HAR

Sur cette page:

À propos de la génération de fichiers HAR

Parfois, l’équipe d’assistance Authentification unique de Qualtrics peut demander un fichier HAR pour déterminer pourquoi un problème se produit sur votre navigateur ou votre réseau. Un fichier HAR est un journal des requêtes réseau qui se produisent dans votre navigateur. Il est important de générer le fichier HAR pendant que le problème que vous rencontrez se produit. Selon le navigateur que vous utilisez, la façon dont vous allez télécharger votre fichier HAR est différente. Ci-dessous, nous vous expliquons comment générer un fichier HAR pour différents navigateurs.

Attention : si vous générez votre fichier HAR lors de la connexion à Qualtrics (c.-à-d. lorsque vous saisissez votre mot de passe sur un écran de connexion), le fichier HAR contiendra votre mot de passe Qualtrics. Veuillez ouvrir votre fichier dans un éditeur de texte, rechercher « password » (mot de passe) et supprimer le mot de passe du fichier avant de l’envoyer au support technique.
Attention : il est important de générer le fichier HAR lorsque l’erreur se produit. Avant de générer le fichier, lisez les étapes pour votre navigateur, afin de savoir quand vous devez reproduire l’erreur.
Attention : bien que les captures d’écran représentent la génération d’un fichier HAR sur un Mac, les étapes pour Windows sont très similaires. Si vous utilisez Windows, vous pouvez cliquer sur la touche F12 de votre clavier pour ouvrir les Outils de développement dans votre navigateur.

Générer un fichier HAR dans Chrome

  1. Ouvrez Google Chrome et accédez à la page où le problème se produit.
  2. Dans la barre de menu Chrome, allez dans View (Affichage) → Developer (Développement) → Developer Tools (Outils de développement).
    Image du menu Outils de développement dans Chrome
  3. Dans le panneau qui s’ouvre, accédez à l’onglet Network (Réseau).
    Image de l’onglet Network (Réseau) dans Chrome
  4. Dans le coin supérieur gauche du panneau se situe un bouton rond Record (Enregistrer). Assurez-vous qu’il est rouge. Si le bouton est gris, cliquez une fois dessus pour le faire passer au rouge.
    Image du bouton rouge Record (Enregistrer) dans Chrome
  5. Cochez la case Preserve Log (Conserver le journal).
    Image de l’option Preserve Log (Conserver le journal) dans Chrome
  6. Cliquez sur le bouton Clear (Effacer) pour effacer tous les journaux existants.
    Image du bouton Clear (Effacer) dans l’onglet Réseau de Chrome
  7. Reproduisez le problème pour enregistrer les journaux réseau.
  8. Une fois que vous avez reproduit le problème, cliquez avec le bouton droit n’importe où dans les journaux réseau et sélectionnez Save all as HAR with content (Enregistrer tout au format HAR avec le contenu). Enregistrez ce fichier sur votre ordinateur.
    Image de l’option Save all as HAR (Enregistrer tout au format HAR) avec le contenu dans Chrome

Générer un fichier HAR dans Safari

  1. Ouvrez Safari et allez à la page où le problème se produit.
  2. Assurez-vous que le menu Develop (Développement) est activé pour Safari. Pour ce faire, allez dans Preferences (Préférences) → Advanced (Avancé) → Show Develop menu (Afficher le menu Développement) dans la barre de menu.
    Image montrant Show Develop menu (Afficher le menu Développement) dans l’option de la barre de menu du menu Preferences (Préférences) dans Safari
  3. Cliquez sur Develop (Développement) dans le menu et sélectionnez Show Web Inspector (Afficher l’inspecteur Web).
    Image de l’option Show Web Inspector (Afficher l’inspecteur Web) dans Safari
  4. Cliquez sur l’onglet Network (Réseau) et recréez le problème.
    Image de l’onglet Network (Réseau) dans Safari
  5. Cliquez sur Export (Exporter) et enregistrez le fichier sur votre ordinateur.
    Image d’une page Web sur Safari avec l’inspecteur Web ouvert. Le bouton Export (Exporter) dans l’onglet Network (Réseau) est mis en surbrillance pour le téléchargement du fichier HAR.

Générer un fichier HAR dans Firefox

  1. Ouvrez Firefox et accédez à la page où le problème se produit.
  2. Cliquez sur l’icône de menu, puis sélectionnez Web Developer (Développement Web). Dans le menu Web Developer (Développement Web), sélectionnez l’option Network (Réseau).
    Image de l’option Web Developer (Développement Web) dans Firefox
  3. Dans le panneau qui apparaît, accédez à l’onglet Network (Réseau).
    Image de l’onglet Network (Réseau) dans Firefox
  4. Recréez le problème dans la fenêtre de votre navigateur. Le panneau démarre l’enregistrement lorsque vous effectuez des actions dans votre navigateur.
  5. Cliquez avec le bouton droit n’importe où dans le tableau des journaux réseau et sélectionnez Save all as HAR (Enregistrer tout au format HAR). Enregistrez ce fichier sur votre ordinateur.
    Image de l’option Save All As HAR (Enregistrer tout au format HAR) dans Firefox

Générer un fichier HAR dans Microsoft Edge

  1. Ouvrez Microsoft Edge et accédez à la page où le problème se produit.
  2. Dans la barre de menu, allez dans Tools (Outils) → Developer (Développement) → Developer Tools (Outils de développement).
    Image du menu des outils de développement dans Microsoft Edge
  3. Dans le panneau qui s’ouvre, accédez à l’onglet Network (Réseau).
    Image de l’onglet Network (Réseau) dans Microsoft Edge
  4. Reproduisez le problème dans votre navigateur.
  5. Cliquez sur le bouton Download (Télécharger) (flèche pointant vers le bas) pour télécharger le fichier HAR sur votre ordinateur.
    Image du bouton Download (Télécharger) dans Microsoft Edge

Générer un fichier HAR dans Internet Explorer

  1. Ouvrez Internet Explorer et accédez à la page où le problème se produit.
  2. Cliquez sur l’icône d’engrenage et sélectionnez Developer Tools (Outils de développement).
    Image des outils de développement dans Internet Explorer
  3. Dans le panneau qui s’ouvre, sélectionnez l’onglet Network (Réseau).
    Image de l’onglet Network (Réseau) dans Internet Explorer
  4. Reproduisez le problème dans votre navigateur.
  5. Lorsque vous avez terminé, cliquez sur le bouton Export as HAR (Exporter au format HAR).
    Image du bouton Export as HAR (Exporter au format HAR) dans Internet Explorer
  6. Donnez un nom à votre fichier et sélectionnez Save (Enregistrer).