HARファイルの生成

このページの内容:

HARファイルの生成について

クアルトリクスSSOチームが、お使いのブラウザーまたはネットワークで問題が発生している原因のトラブルシューティングのために、HARファイルを依頼する場合があります。HARファイルは、ブラウザーで起きているネットワークリクエストのログです。問題発生中にHARファイルを生成することが重要です。ブラウザーによって、HARファイルのダウンロード方法が異なります。以下、さまざまなブラウザーのHARファイル生成方法をご案内します。

注意:クアルトリクスにログインしたまま(ログイン画面にパスワードを入力した状態で)HARファイルを生成する場合、HARファイルの中にクアルトリクスのパスワードが含まれます。テキストエディターでファイルを開き、「パスワード(password)」と検索して、サポートチームにファイルを送信する前にパスワードを削除してください。
注意:エラーを再現している間にHARファイルを生成することが重要です。ファイルを生成する前にお使いのブラウザー用手順を確認し、エラーを再現する必要があるタイミングで実施します。
注意:MacでのHARファイルを生成するスクリーンショットを掲載していますが、Windowsでのステップもほぼ同様です。Windowsを使用の場合は、キーボードの「F12」キーを押して、ブラウザーで開発者ツールを開きます。

ChromeでHARファイルを生成

  1. Google Chromeを開き、問題が発生しているページへ移動します。
  2. Chromeのメニューバーで[表示]→ [開発者]→ [開発者ツール]の順に移動します。
    Chromeの開発者ツールメニューの画像
  3. パネルが開いたら、[Network(ネットワーク)]タブに移動します。
    Chromeの[Network(ネットワーク)]タブの画像
  4. パネルの左上の隅に、丸いレコードボタンがあります。ボタンが赤であるかを確認してください。ボタンがグレーの場合は、一度クリックして赤に変更します。
    Chromeの赤い丸のレコードボタンの画像
  5. Preserve log(ログを保存)]ボックスにチェックマークを入れます。
    Chromeの[Preserve log(ログを保存)]オプションの画像
  6. 既存のログを消去するには、クリアボタンをクリックします。
    Chromeのネットワークタブにあるクリアボタンの画像
  7. 問題を再現し、ネットワークログを記録します。
  8. 問題を再現したら、ネットワークログの任意の場所を右クリックして[コンテンツ付きのHARとしてすべて保存]を選択します。ファイルをコンピュータに保存します。
    Chromeの[コンテンツ付きのHARとして全て保存]オプションの画像

SafariでHARファイルを生成する

  1. Safariを開き、問題が発生しているページへ移動します。
  2. Safariの[開発メニュー]が有効化していることを確認します。確認するには、[環境設定]→ [詳細]→ [メニューバーに開発メニューを表示]の順に移動します。
    Safariの[環境設定]メニューの[メニューバーに開発メニューを表示]オプションの画像
  3. メニューで[開発]をクリックし、[Webインスペクタを表示]を選択します。
    Safariの[Webインスペクタを表示]の画像
  4. ネットワーク]タブをクリックして問題を再現します。
    Safariの[ネットワーク]タブの画像
  5. エクスポート]をクリックしてコンピュータにファイルを保存します。
    SafariでWebインスペクタを開いた状態のページの画像 [ネットワーク]タブの[エクスポート]ボタンはHARファイルのダウンロード用にハイライトされています。

FirefoxでHARファイルを生成

  1. Firefoxを開き、問題が発生しているページへ移動します。
  2. メニューアイコンをクリックし、[ウェブ開発者]を選択します。ウェブ開発者メニューで、[ネットワーク]オプションを選択します。
    Firefoxの[ウェブ開発者]オプションの画像
  3. 表示されるパネルで、[ネットワーク]タブに移動します。
    Firefoxの[ネットワーク]タブの画像
  4. ブラウザーウィンドウの問題を再現します。ブラウザーでアクションを実行すると、パネルが記録を開始します。
  5. ネットワークログのテーブルで任意の場所を右クリックし、[HAR形式ですべて保存]を選択します。ファイルをコンピュータに保存します。
    Firefoxの[コンテンツ付きのHARとして全て保存]オプションの画像

Microsoft EdgeでHARファイルを生成

  1. Microsoft Edgeを開き、問題が発生しているページへ移動します。
  2. メニューバーで[ツール]→ [開発者]→ [開発者ツール]の順に移動します。
    microsoft edgeの[開発者ツール]メニューの画像
  3. パネルが開いたら、[Network(ネットワーク)]タブに移動します。
    microsoft edgeの[ネットワーク]タブの画像
  4. ブラウザーの問題を再現します。
  5. [ダウンロード]ボタン(下矢印)をクリックしてコンピュータにHARファイルをダウンロードします。
    microsoft edgeの[ダウンロード]ボタンの画像

Internet ExplorerでHARファイルを生成

  1. Internet Explorerを開き、問題の発生しているページへ移動します。
  2. 歯車アイコンをクリックして[開発者ツール]を選択します。
    internet explorerの[開発者ツール]の画像
  3. パネルが開いたら、[ネットワーク]タブを選択します。
    internet explorerの[ネットワーク]タブの画像
  4. ブラウザーの問題を再現します。
  5. 完了したら、[HARとしてエクスポート]ボタンをクリックします。
    internet explorerの[HARとしてエクスポート]ボタンの画像
  6. ファイルに名前を付けて保存します。