Skip to main content
Loading...
  • Customer Experience
    Customer Experience
  • Employee Experience
    Employee Experience
  • Brand Experience
    Brand Experience
  • Product Experience
    Product Experience
  • Core XM
    Core XM
  • Design XM
    Design XM

Importing Responses (360)

What's on This Page:


Was this helpful?


This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

The feedback you submit here is used only to help improve this page.

That’s great! Thank you for your feedback!

Thank you for your feedback!


Qtip: Contact your Customer Success Representative or your Account Executive for pricing on importing. Imported responses are considered separate from and will not impact the account’s purchased participants.

About Importing Responses

You can use the Import Data option in the Data tab to upload test or example data, to add multiple responses for a single participant, or to upload data collected externally.

Qtip: This page is for importing responses into 360. If you are interested in learning how to import your list of participants, please visit our Adding Subjects, Evaluators, & Managers support page.
Attention: Before importing your responses, it’s important to have already added your participants with their relationships to your project. If your responses are imported without having defined your participants and their relationships, the imported data will not be tied to any participants and will not appear in your report.

Preparing Your Data

You will need to make sure your data file is ready for import. Your data needs to be in a format Qualtrics will understand, and it needs to exactly match the format and content of the survey you’re importing the data into.

To get a template for a data set you can import, you will need to export the data in Legacy format.

Getting a Template File

  1. Navigate to your Data tab.
    Export Data option within the Export & Import dropdown menu
  2. Click Export & Import.
  3. Select Export Data.
  4. Click Use Legacy Exporter.
    Use Legacy Exporter option in the upper right corner of the Download Data Table pop up window
  5. Make sure CSV is selected.
    CSV is selected and Download Evaluation Status is selected
  6. Select Download Evaluation Status.
  7. Click More Options.
  8. Make sure Use numeric values is selected.
    Scrolling through more options on the export data set window
  9. Click Download.

Your file will look similar to this:

File with ID, name, and email for subject and evaluator, date, scoring, questions, etc

File Requirements

For the import to work, the data file needs a special column that identifies the participant the response is from. You have to include each of the following:

  • Email: A column named Email containing the evaluator’s email. (In the file you exported earlier, rename the EvaluatorEmail column to Email.) These emails must be spelled the same as they are in the Participants section, but they are not case-sensitive.
  • Relationship: Note the relationship between the subject and the evaluator. Be sure to capitalize where necessary.
  • EvaluatorID and SubjectID: Qualtrics has internal IDs it uses to identify each participant (e.g., P_1ABb2dE3f4GhI5j). The inclusion of these columns also makes it so you don’t need to include metadata in your import. The importer recognizes the participant by their ID, and associates the appropriate participant metadata with the response.

When working with the example file, you can also make the following changes:

  • Keep the first row of “V” headers – e.g., V1, V2, etc.
  • Under each question the participant can answer, make sure you add the recode value for the answer (not the text of the answer).
  • Remove rows of evaluations that are complete or that you do not want to import.
  • The following columns cannot be updated with the response data. You are free to delete them from the file; otherwise, they will be ignored during import:
    • Approved
    • Scoring columns
    • SubjectFirstName
    • SubjectLastName
    • EvaluatorFirstName
    • EvaluatorLastName
    • IP Address
    • ResponseSet
    • Response ID
    • Status
    • Assorted metadata
Qtip: Looking to change your participant metadata? Check out our support page on importing metadata updates.

After you make these changes, your file will look something like this:

A much shorter file - no extraneous name columns, no scoring information, no rows for participants who already had data

Be sure to keep your file in CSV (UTF-8 encoded) or TSV format. The importer cannot read any other file types, even if they can also be read by Excel.

Note that the maximum file size is 100MB, with a maximum of 5000 rows.

Importing Your Responses

  1. Navigate to the Data tab.
    Import Data option within the Export & Import dropdown menu
  2. Click Export & Import.
  3. Select Import Data.
  4. Click Use Legacy Importer.
    Use Legacy Importer option in the top right corner of the Upload Response Data pop up window
  5. Click Browse and select the CSV file you saved on your computer.
    Import Responses pop up window
  6. If desired or necessary, click More Options to access Delimiter, Enclosure, or to Allow Duplicate Responses.
    Qtip: If the data is not formatted correctly in the preview (e.g., bunched up instead of divided into columns), your data may not be separating (or “delimiting”) correctly. To fix this, choose a different delimiter. For further troubleshooting techniques, visit our CSV/TSV Upload Issues page.
  7. Check that the number of responses verified is the number of responses in your CSV file.
    Warning: If the number of responses shown does not match the number you have in your CSV file, then do not click Import Responses. If you do, the responses will not import correctly and you will need to delete the invalid data.
  8. Click Import.
    Qtip: Remember, you need an Email column with the evaluator’s email before the response data will import!

Once the data is imported, a notice will appear detailing the number of successfully imported responses and any columns and rows that were skipped.

Qtip: Under More Options, if you do not switch Allow Duplicate Responses to Yes, any participants whose responses were already collected will be skipped over. Keeping this setting turned off ensures the data will not be changed for duplicate participants. See our Response Editing and Retake Survey Link pages for information on editing your existing data.

If you are not using one of the provided delimiters in the More Options menu, you can click into the Delimiter text box and type the symbol of the delimiter being used.

Delimiter option within the Import Responses pop up window