Loading...
  • Customer Experience
    Customer Experience
  • Employee Experience
    Employee Experience
  • Brand Experience
    Brand Experience
  • Product Experience
    Product Experience
  • Core XM
    Core XM

Import Responses

What's on This Page:


Was this helpful?


This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

The feedback you submit here is used only to help improve this page.

That’s great! Thank you for your feedback!

Thank you for your feedback!


Qtip: Contact your Customer Success Representative or your Account Executive for pricing on importing. Imported responses are considered separate from and will not impact the account’s response limit.

About Importing Responses

You can use the Import Data option in the Data & Analysis tab to combine responses from two identical surveys, re-upload edited data, or bring in your own data.

Preparing Your Survey

Before importing, you’ll first need a survey to import your data to. Your survey’s format and your data file format must match exactly. This can be achieved using one of these three options:

  • The survey you downloaded the data from
  • A copy of the survey you downloaded the data from
  • A survey identical to the one that collected the data you are importing.

Preparing a File

The Table importer allows you to upload responses without perfecting your data file, giving you the ability to re-order columns, adjust the timezone, specify values, and more. However, even if your file contains a few correctable errors, you still have to make sure that your data is presented in a format Qualtrics can read.

The easiest way to prepare your file is to export a Data Table file in CSV or TSV format. However, so long as you use the same format for each column’s header, you can also use a TXT file.

Qtip: TSVs are recommended if the language of your responses contains special characters.

If you try to import a Legacy export instead, then you will be redirected to the Legacy importer. The Legacy importer requires that the order of your columns be perfected before import, and does not contain the same advanced settings that the Table importer does.

Importing Responses

  1. Navigate to the Data section on the Data & Analysis tab.
    Import Data option from Export & Import dropdown in Data & Analysis tab
  2. Click on Export & Import.
  3. Select Import Data.
  4. Click Browse and select the file you wish to upload. This can be in CSV, TSV, or TXT format.
    Upload Response Data menu with Browse button, Delimiter dropdown, and Upload button
  5. If desired, adjust your Delimiter. Generally this is set to Comma for CSV and Tab for TSV.
    Qtip: This option is especially helpful if you are uploading a TXT file. You can specify your delimiter here.
  6. Click Upload.
    Qtip: If you’re uploading a Legacy export that you edited, then you will be redirected to the Legacy importer after completing this step.
  7. On this window, you can check whether your fields are pulling in correctly and assign different values. See the Configuring Your Import section below for more information on this part of the process.
    Configure the Import menu, with button to Import Reponses
  8. Click Import Responses.
Qtip: Each imported response is a new response in your survey. Importing data in this way does not replace pre-existing responses. For example, if you upload the same data you exported back into your survey, you will have duplicated responses.
Qtip: If you’ve exported your data to re-import after editing the data, note that the RecordedDate will be overwritten. When you import your responses, the new RecordedDate will be the time you imported the responses. The EndDate field will still have the time that the respondent submitted their response. You can read more about these fields on the Understanding Your Data Set page.
Qtip: If you have a Sensitive Data Policy in place, note that Imported Responses will be excluded from redaction.

Configuring Your Import

After you’ve selected the file you want to upload, you have a chance to check the file’s contents and make formatting changes right inside Qualtrics. This saves you time, so that you don’t have to open your file in Excel and make edits.

The settings described below only apply to the default importer. The Legacy importer does not have these options.

Correcting Columns

Did some of your columns come in out of order? Maybe there are certain variables you don’t want to import at all. Click on the column header to either change the variable or select to Ignore the contents.

List of questions and embedded fields in the Configure the Import menu

When a column is ignored, the variable is not deleted from Qualtrics, but the data from the column will not upload.

Qtip: Some columns are ignored by default. For example, you cannot import Formulas or Bucketed fields. Once their rules are set and data for the questions these rules are based on are uploaded, Qualtrics calculates Formulas and Bucketed fields for you.

Mapping Values

Sometimes even after cleaning your data, you’ll find small errors. Maybe an answer was consistently misspelled when entered into the Excel sheet. Maybe your capitalization is wrong, or you accidentally used the wrong recode values. Mapping values allows you to adjust your import without having to reopen your file and make edits.

To get started, click the dropdown arrow next to Mapping Values to expand the list of possible values.

Mapping Values option with choices displayed within Configure the Import menu

On the right are the possible choices for the question. Since in the example here the question is “How satisfied are you with our product,” the possible answers range from Extremely Satisfied to Extremely Dissatisfied on a five point scale.

On the left are the exact values typed into the data file. Ideally, these should be exactly the same, but in cases where you might have mistyped a few entries or mixed choice text and numeric data together, you may want to add additional values here.

To add another value, click the plus sign ( ), then select the answer choice that the new value is going to correspond to.

Plus button underneath choices to add another choice

Hover over the value and click the minus () sign to eliminate a choice.

The new value will appear at the bottom of the list. You can modify the label on the left and the value on the right. You can add values as many times as you need to.

Example: Let’s say your team manually entered some of the data into your file. One assistant accidentally wrote answer choices in all lowercase, and another wrote the numeric recode values of the choices instead of the choice text labels. In the screenshot below, both the lowercase version and recode value have been added for Extremely Satisfied.
Text Entry boxes to add additional mapping values
Qtip: Mapping values does not create new answer choices! It is a way of mapping the values from your file to existing values in your project.

Download and Load Settings

When you click Download Settings, you will receive a JSON file of the settings used for the Import.

Download Settings option in bottom-left corner or Configure Import menu

To reuse these settings on future imports, click More Options then Load Settings and select the settings file.

Load Settings option in bottom right and Few Options in bottom left of Configure Response

This option can be helpful if you are adept at JSON. If you do not know JSON, it is advised that you do not try to edit this file.

More Options

When you click More Options on the bottom-left of your Load Settings tab, you will be provided additional settings for your importer.

Load Settings option in bottom right and Few Options in bottom left of Configure Response

  • Timezone: Determine the timezone of the data file. This settings applies to all date fields in the file.
  • Date/Time Format: Determine the date/time format of the whole data file. If you exported the file from Qualtrics, the importer will try to detect the timezone you set on your account at the time the file was exported.
  • Response start at row number: The importer usually detects this automatically. This setting determines the row where your headers end and data begins. For example, if this says 4, that means there are three rows of headers.

Troubleshooting Table Imports

The Table importer is the default importer when importing responses.

  • The Table importer only accepts comma and tab separated files. If you’re not using a comma or tab as a delimiter, you’ll need to use the Legacy Importer to import your responses.
    Image showing available delimiters in the table importer
  • If some of your fields are being skipped or your imported values don’t align with your survey questions, you’ll want to check your question mapping from within the import window. See the Configuring Your Import section for tips on reviewing your file from within the data importer.
    Image showing how to map columns/answer choices in importer
  • If your data is importing with characters you don’t recognize, your file is saved in an incompatible format. You will need to save your file as a TSV or CSV with UTF-8 encoding. For more tips troubleshooting CSV formatting, read the CSV/TSV Upload Issues page.
    image of importer preview with misconfigured file

Preparing Your Data for the Legacy Importer

If you manually choose the Legacy importer or are making edits to a Legacy export, then you will not be able to make corrections inside Qualtrics when you import the data. Instead, you will have to make sure your data file is ready before trying to import it.

The Legacy importer is compatible with two formats:

  • The Example CSV Qualtrics provides for your survey, and input your data into that file (best if you want to import brand new responses)
  • The Legacy export (best if you want to edit existing data)

You can enter or adjust data as necessary.

To export and edit the Example CSV

  1. Navigate to the Data section of the Data & Analysis tab.
  2. Select Import Data from the Export & Import dropdown.
    Import Data option from Export & Import dropdown in Data & Analysis tab
  3. Click Use Legacy Importer.
    Use Legacy Importer option in top-right corner of Upload Response Data menu
  4. Click Example CSV.
    Example CSV located on the righthand side of Import Responses menu
  5. Open the downloaded CSV file in Excel and input/paste your new data into the appropriate cells. For data imported into non-text entry question types, you must use the question’s recode values.
    Correctly formatted CSV file in a spreadsheet

    Qtip: You can delete any columns in the example file that you don’t need, but be careful when adding new ones. When importing, Qualtrics will skip columns that don’t correctly align with the questions or Embedded Data in your survey.
  6. Save the file as a CSV.
Qtip: The QID numbers in the second row of the Example Document are Qualtrics internal IDs. Note that these numbers may be different than the question numbers in your survey and cannot be changed.

Once your data file is prepared, you can import it into a survey in your account.

 

Qtip: You can also use a Qualtrics exported data file from a survey as your import file.

To export and edit existing data

To export an existing data file, follow the steps on our Export Data Overview page to get a file in Legacy format. Once you have the CSV downloaded and open in Excel, you can edit individual cells as needed.

Editing existing data in a spreadsheet

Qtip: You can delete any columns in the example file that you don’t need, but be careful when adding new ones. When importing, Qualtrics will skip columns that don’t correctly align with the questions or Embedded Data in your survey.

Once your data file is prepared, you can import it into a survey in your account. Note that for importing altered responses, we recommend importing them into a copy of the original survey. If they are imported into the existing survey, you will have the original responses and the adjusted ones together in one dataset (i.e. duplicates).

Importing A Legacy File

  1. Navigate to the Data section of the Data & Analysis tab.
  2. Select Import Data from the Export & Import dropdown.
    Import Data option from Export & Import dropdown in Data & Analysis tab
  3. Click Use Legacy Importer.
    Use Legacy Importer option in top-right corner of Upload Response Data menu
  4. Click Browse and select your CSV file saved on your computer.
    Browse button in Import Responses menu
  5. Verify that the data columns have been imported correctly.
    Verify Fields section with a few rows and columns of data
  6. If desired or necessary, click More Options to access Delimiter, Enclosure, and other settings.
    More Options found in bottom-left corner of Import Responses menu

    Qtip: If the data is not formatted correctly in the preview (e.g., bunched up instead of divided into columns), your data may not be separating (or “delimiting”) correctly. To fix this, choose a different Delimiter. For further troubleshooting techniques, visit our CSV/TSV Upload Issues page.
  7. Check that the number of responses verified is the number of responses in your CSV file.
    Verify Fields section with a few rows and columns of data

    Warning: If the number of responses shown does not match the number you have in your CSV file, then do not click Import Responses. If you do, the responses will not import correctly and you will need to delete the invalid data.
  8. Click Import Responses.
    Import Responses button in bottom-right corner of Import Responses menu

Once the data is imported, a notice will appear detailing the number of successfully imported responses and any columns and rows that were skipped.

Qtip: Exported data files include columns that will always be skipped on import. These are ResponseID, Status, contact list fields (First Name, Last Name, Email, etc.), and location fields (Longitude, Latitude, Accuracy). It is not possible to set these fields for imported responses, but if you would like to keep the data, you can add Embedded Data fields and include your data there. Note that these new Embedded Data fields would also first have to be added to your Survey Flow in order to import properly.

Troubleshooting Legacy Imports

  • If you are not using one of the provided Delimiters in the More Options menu, you can click into the Delimiter text box and type the symbol of the delimiter being used.
    Delimiter dropdown list under the Browse button within More Options
  • If your file is not importing, it could be due to validation in your survey. To ignore validation while importing, select More Options and click the Do not validate checkbox.
    Checkbox to disable validation

FAQs