Loading...
  • Customer Experience
    Customer Experience
  • Employee Experience
    Employee Experience
  • Brand Experience
    Brand Experience
  • Product Experience
    Product Experience
  • Core XM
    Core XM

Advanced-Reports Basic Overview

What's on This Page:


Was this helpful?


This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

The feedback you submit here is used only to help improve this page.

That’s great! Thank you for your feedback!

Thank you for your feedback!


About Advanced-Reports

The end goal of Advanced-Reports is to create informative online and printed reports to share with your stakeholders.

Advanced-Reports provide the layout tools you’ll need to design:

  • Page Layouts: Collections of visualizations with accompanying headers, themes, color schemes, margins, and fonts.
  • Visualizations: Individual charts, images, graphs, text areas, or tables pulled from your data set.
  • Filters: Logic to include or exclude data from your visualizations and reports.

Creating an Advanced-Report

To start an initial advanced-report:

  1. Select the Reports tab.
  2. Pick the Reports section.
  3. Choose Create a report.
    Display of how to create a new report

You must select between three options (New Report, From Results Report, or From QRF):

the create report screen

  1. New Report: Start a blank, new report from scratch.
  2. From Results Report: Begin with a previously saved Results-Report.
    Qtip: This is an easier path for new users. Read the Results-Reports Basic Overview for details.
  3. Import from QRF: Import a Qualtrics Report File (QRF) from a previously made report to carry over all settings and visualizations. See Creating an Advanced-Report from QRF for more information.
  4. Name the report and verify its initial page layout settings (e.g., Page Size, Orientation, and Margins).
  5. Click Create to continue.
    Qtip: Don’t stress over your initial settings. You can easily change them later in the Page section of your Global Settings.

The Page Layout Toolbar

After the initial set up, your layout tools will be accessible from the Advanced-Reports toolbar. From this toolbar you can:

Toolbar above the report

  1. Switch between multiple reports or begin a New one from the Report dropdown menu. (The active report is indicated by a checkmark.)
  2. Use the File, Edit, View, and Insert menus to make increasingly granular changes to your layouts.
    Qtip: Review all the features in each menu option in the Advanced-Reports Toolbar page.

Creating an Advanced-Report from QRF

  1. In a report that you’ve already built, click File.
    to export the QRF of a report, select File and then export to QRF
  2. Choose Export to QRF.
  3. Create a new report. This doesn’t have to be in the same project as the original report.
  4. Select Import from QRF.
    importing a QRF file. select import from QRF and select the file, give the report a name, and choose its layout settings
  5. Click Choose a file and select the downloaded QRF on your computer.
  6. Give your file a name.
  7. Select the data source of the report. This is the survey that the report will pull the data from. You must select a survey that’s part of the project you’re importing the QRF into.
  8. Click Create.

About Page Layouts

In your page layouts you can:

Insert menu expanded along the top and Remove button of visualization editing pane indicated on the right

  1. Insert Text Areas, Images, Visualizations, Page Breaks, Headers, and Footers.
  2. Edit headers.
  3. Position graphics.
  4. Format text areas.
  5. Display gridlines to guide the positioning of elements.
  6. Remove elements.
    Qtip: Jump to the Inserting Advanced-Reports Content page to learn how to add and adjust report content.

About Visualizations

If you need a single, custom visualization, style it in a page layout and export it as a JPEG image or Microsoft Word document.

To design a visualization:

  1. Click the visualization you wish to style.
  2. To add a title, select Options > Insert Title.
    Options button above a visualization
  3. Use the Rich Content Editor, found under the Advanced-Reports toolbar, to style your text (e.g., choose the font color tool and use hexadecimal codes or the color selector to select your colors).
    Rich content editor
  4. Under Visualization, choose the visualization type that best represents your data.
    The visualization editing pane
  5. Click the more options icon at the end of the list to display additional visualization types.
  6. Sort through the options in the editing pane, picking elements that fit your needs, such as adjusting your Large Labels, Small Labels, and Legend.
  7. Play with color schemes by clicking the Color Palette dropdown.
  8. If you need to apply a branded color scheme, enter the colors based on approved company/institution hexadecimal color codes.
    Legend with adjustable colors in the visualization editing pane

Sharing a Single Visualization

Create and share individual visualizations by re-styling visualizations and exporting them as a JPEG image (.jpg) or Microsoft Word (.docx) from the visualization Options.

Visualization with the options button expanded

Customizing Visualizations

Qualtrics offers a dozen question types each with its own unique visualization styling options. Refer to the visualization-specific explanations (e.g., Gauge Chart Visualization or Word Cloud Visualization) as grouped under these three headings on the Support Site:

  1. Charts
  2. Tables
  3. Other

Support site menu with Visualization categories highlighted

About Filtering

Filtering excludes information from visualizations and reports. Several data sources can be used to define the condition necessary to create a filter, specifically:

  1. Question Answers: When filtering by question answers, you’ll interact with field names and values. Field names act as variables (e.g., Gender, State, Status). Fields can have multiple values. For example, the field “Canadian Provinces” may have Ontario, Newfoundland, and British Columbia as values. See Fields You Can Filter By for more information.
  2. Survey Metadata: Includes information automatically collected when a respondent takes a survey, such as Start Date, End Date, Response Type, IP Address, Duration, Finished, and RecordedDate. See Fields You Can Filter By for more information.
  3. Embedded Data: Includes extra information recorded in your project beyond question responses and metadata, consisting of fields and values that can be effectively filtered. See Embedded Data for more information.

Apply your filters at two different levels:

Filters on the upper-right of the Reports section and on the visualization editing pane

  1. Global Filters: Click the Filters option in the Advanced-Reports toolbar to filter an entire report.
  2. Visualization-Level Filters: Pre-select the specific visualization you want to filter and choose the Filters option from that visualization’s editing pane.

Applying Global Filters

If you choose to apply global filters, all of the individual visualizations in a report will assume these filters as their presets. For example, if you exclude all participants under the age of 21, you will not be able to include this demographic in any of your  visualizations.

Filters are set by creating conditional statements which use ALL or ANY to drive your filtering criteria, operators, and operands (i.e., values).

Filters menu

  1. All: All conditions must be met. Similar to “And.”
  2. Any: At least one condition must be met. Similar to “Or.”
  3. Filter Criteria: Choose between Question Answers, Survey Metadata, or Embedded Data.
  4. Operator: Apply a logic operator to launch your decision criteria (e.g., is / is not, equal to / not equal to, and / or, and more).
  5. Operand (i.e., value): Apply numeric values or character strings to evaluate your conditional statements.

Conditions are managed in the Filters popup window opened by selecting Filters from the Advanced-Reports toolbar. In this window click:

Managing filter conditions

  1. Insert New Condition: Add as many filters as you need.
  2. Insert New Condition Set: Organize related filters into subcategories.
  3. Minus Sign ( – ): Remove or delete filters by clicking a the minus sign (  ) next to each one.
  4. Save and Apply: Save your filters and exit the Filters popup window.
Qtip: Filtering is explained in detail in the Global Advanced-Reports Filters page.

Applying a Filter to a Visualization

Visualization-level filters can dramatically change a single visualization without impacting the rest of the Advanced-Report. To apply a visualization filter:

  1. Select the visualization you wish to filter.
    Filters on the visualization editing pane
  2. Click Filters from the visualization editing pane.
  3. The Filters popup window will appear.
  4. Decide between the “Any” and “All” variables.
  5. Select a Data Source (such as a question).
  6. Select an Operator.
  7. Select an Operand (i.e., value).
  8. Click Add Filter to add additional conditions to your filter.
  9. Select Save and Apply.
Qtip: Learn more by reviewing the Global Advanced-Reports Filters page.

About Sharing Reports (in Print or Online)

After you finish your page layouts, there are two ways to share your Advanced-Reports. See Sharing Your Advanced-Reports to learn more.

  1. Exporting a PDF: Create a hard copy of your report by navigating to Share > Download PDF. This will generate a PDF file that can be shared (i.e., as an attachment to an email) or printed for hard copy distribution.
  2. Sharing a Public Report:. The easiest way to share an Advanced-Report with non-Qualtrics users is with a public report link that is generated by navigating to Share > Manage Public Report.

FAQs